In HP-UX 11i v3, when you issue smh (new sam command), it will bring you the new firefox smh browser.
If you wish to use back the old terminal sam, issue the command below.
#unset DISPLAY ; /usr/sbin/smh
Note that this will not change permanently.
Custom Search
Wednesday, February 18, 2009
Saturday, February 14, 2009
How to install .depot files
For example, you want to install software.depot file
In root, issue the command
#swinstall -s /tmp/software.depot
Make sure you define the full path working directory where the file is.
In root, issue the command
#swinstall -s /tmp/software.depot
Make sure you define the full path working directory where the file is.
Changing hostname & IP address
To change, edit the following file below
#vi /etc/rc.config/netconf
After that you will need to restart the services.
#cd /sbin/init.d
#./net stop
#./net start
#./hostname start
#vi /etc/rc.config/netconf
After that you will need to restart the services.
#cd /sbin/init.d
#./net stop
#./net start
#./hostname start
Checking the World Wide Name (WWN) on HP-UX
Assuming that you have a HBA (Fiber Channel) Card installed on your server.
Issue the command ioscan -nfC FC
Get the device path for the desire FC.
e.g. /dev/fcd0
Issue the command
#fcmsutil /dev/fcd0
Look for the line below.
N_Port Port WWN:
That will be your WWN for that fiber port. Good luck!
Issue the command ioscan -nfC FC
Get the device path for the desire FC.
e.g. /dev/fcd0
Issue the command
#fcmsutil /dev/fcd0
Look for the line below.
N_Port Port WWN:
That will be your WWN for that fiber port. Good luck!
Recall command history on HP-UX
To recall the commands that you have issued in HP-UX, change the shell to korn shell.
#ksh -o vi
Press ESC and K on the keyboard.
#ksh -o vi
Press ESC and K on the keyboard.
Wednesday, February 4, 2009
2 ways to increase the swap space
- By using SAM
SAM > Disk and File Systems > Swap > Actions
You can add the Device Swap or File System Swap. - By Command Line
Create the logical volume for your secondary swap:
# lvcreate -L 128 /dev/vg14
NOTE: "-L 128" is the size of desired swap
Verify the logical volume:
# lvdisplay /dev/vg14/lvol15
Use SAM to declare your new secondary swap or use the command line:
# swapon /dev/vg14/lvol15
Verify it has been added in "/etc/fstab" when using SAM, or add it manuallywhen using the command line.
Example:
/dev/vg14/lvol15 . swap defaults 0 0
ioscan
To view a list of peripherals on the server, issue the command...
The next time you want to view it again, you can use the -k option for cache so that you don't have to wait for it to scan the entire system again.
For example...
ioscan -knfC disk
- For HDD
ioscan -nfC disk - For tape drive
ioscan -nfC tape - For LAN - Ethernet Card
ioscan -nfC LAN - For FC - Fiber Channel
ioscan -nfC FC
The next time you want to view it again, you can use the -k option for cache so that you don't have to wait for it to scan the entire system again.
For example...
ioscan -knfC disk
Tuesday, February 3, 2009
How to increase the logical volume size?
Before increasin the size of the logical volume, always ensure that you do a make_tape_recovery and fbackup on the data stored on that particular logical volume that you wish to increase.
Always check your current and free lvol size before increasing so you can keep track and notice the differents.
We take a scenario where I would want to increase my /dev/vg00/lvol10 to 1GB
Always check your current and free lvol size before increasing so you can keep track and notice the differents.
We take a scenario where I would want to increase my /dev/vg00/lvol10 to 1GB
- umount /dev/vg00/lvol10
- lvextend -L 1024 /dev/vg00/lvol10
- extendfs -F vxfs /dev/vg00/lvol10
- mount /dev/vg00/lvol10 /myfolder
- bdf
bdf command to check your increased lvol size.
Subscribe to:
Posts (Atom)